Overview
  News
  Feature Overview
  Screenshots
  Requirements
  Download
 
See also
  Documentation
  Plug-ins
  Roadmap
 
  Contact        Search:     
  Home   |   Download   |   Documentation   |   Support   |   Development

Docmenta System Requirements

Client-side:

On client-side Docmenta requires a JavaScript enabled Web-Browser. Officially supported are
  • Firefox 7 or higher
  • Internet Explorer 8 or higher
Docmenta may also work with older versions of Firefox and Internet Explorer, as well as other Browsers like Chrome, Safari and Opera, but these are not officially supported.

Server-side:

  • Java Servlet/JSP container (e.g. Apache Tomcat)
  • Java Runtime Environment (JRE) 5.0 or later

Docmenta is a Java web-application and therefore requires a web-server environment that provides Java Servlet/JSP support.

The Docmenta documentation describes the installation assuming that you use Apache Tomcat version 6.0 or higher. Nevertheless other Java Servlet/JSP containers (e.g. JBOSS, WebSphere, WebLogic, Oracle Server, Jetty, ...) may work as well. But only the Apache Tomcat 6.0 or higher is officially supported. For other web-servers consult the documentation that is provided with your web-server distribution.

If you want to run Docmenta on a MS Windows operating system, you can download a bundled installation package that includes the Tomcat web-server. The installer also has an option to automatically download and install the JRE (Java Runtime Environment) if not already installed on your server machine.

Note: Docmenta can store all information as files in the filesystem, i.e. no database system is required. Since Docmenta version 1.6, embedded and external database storage is available as well. See 'Managing products' in the reference manual for more information.
 
©2016 www.docmenta.org - All rights reserved.